re = /(?i)
(\[)?
(?(1)|(\*)?
(?(2)|(\{)?
(?(3)|(\()?
)))
(?:secure|encrypt)
(?(1)]
|(?(2)\*
|(?(3)}
|(?(4)\)
|(*FAIL)
))))/mx
str = 'Don\'t match:
{secure]
{spatula}
secure[(secure])
~secure~
Match:
[secure]
*ENCRYPT*
{EnCrYpT}
(sEcUrE)
Secure or Encrypt within *,{, [ or ('
# Print the match result
str.scan(re) do |match|
puts match.to_s
end