const regex = /(?i)
(\[)?
(?(1)|(\*)?
(?(2)|(\{)?
(?(3)|(\()?
)))
(?:secure|encrypt)
(?(1)]
|(?(2)\*
|(?(3)}
|(?(4)\)
|(*FAIL)
))))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)
(\\[)?
(?(1)|(\\*)?
(?(2)|(\\{)?
(?(3)|(\\()?
)))
(?:secure|encrypt)
(?(1)]
|(?(2)\\*
|(?(3)}
|(?(4)\\)
|(*FAIL)
))))', 'gm')
const str = `Don't match:
{secure]
{spatula}
secure[(secure])
~secure~
Match:
[secure]
*ENCRYPT*
{EnCrYpT}
(sEcUrE)
Secure or Encrypt within *,{, [ or (`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}