using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)
(\[)?
(?(1)|(\*)?
(?(2)|(\{)?
(?(3)|(\()?
)))
(?:secure|encrypt)
(?(1)]
|(?(2)\*
|(?(3)}
|(?(4)\)
|(*FAIL)
))))";
string input = @"Don't match:
{secure]
{spatula}
secure[(secure])
~secure~
Match:
[secure]
*ENCRYPT*
{EnCrYpT}
(sEcUrE)
Secure or Encrypt within *,{, [ or (";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}