import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\n"
+ "(\\[)?\n"
+ "(?(1)|(\\*)?\n"
+ "(?(2)|(\\{)?\n"
+ "(?(3)|(\\()?\n"
+ ")))\n"
+ "(?:secure|encrypt)\n"
+ "(?(1)]\n"
+ "|(?(2)\\*\n"
+ "|(?(3)\\}\n"
+ "|(?(4)\\)\n"
+ "|(*FAIL)\n"
+ "))))";
final String string = "Don't match:\n"
+ "{secure]\n"
+ "{spatula}\n"
+ "secure[(secure])\n"
+ "~secure~\n\n"
+ "Match:\n"
+ "[secure]\n"
+ "*ENCRYPT*\n"
+ "{EnCrYpT}\n"
+ "(sEcUrE)\n\n\n\n\n"
+ "Secure or Encrypt within *,{, [ or (";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}