// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?i)
(\[)?
(?(1)|(\*)?
(?(2)|(\{)?
(?(3)|(\()?
)))
(?:secure|encrypt)
(?(1)]
|(?(2)\*
|(?(3)}
|(?(4)\)
|(*FAIL)
))))").unwrap();
let string = "Don't match:
{secure]
{spatula}
secure[(secure])
~secure~
Match:
[secure]
*ENCRYPT*
{EnCrYpT}
(sEcUrE)
Secure or Encrypt within *,{, [ or (";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}