# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - / | /gm;t' <<< "Hello - world - I am a good - guy and want to - save - the - world
Hello - wor ld - I am a good - guy and want to - save - the - world
Hello - wo43rld - I am a good - guy and want to - save - the - world
Hello - world 2.0 - I am a good - guy and want to - save - the - world
Hello - world $%& - I am a good - guy and want to - save - the - world"