# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - "
test_str = ("Hello - world - I am a good - guy and want to - save - the - world\n"
"Hello - wor ld - I am a good - guy and want to - save - the - world\n"
"Hello - wo43rld - I am a good - guy and want to - save - the - world\n"
"Hello - world 2.0 - I am a good - guy and want to - save - the - world\n"
"Hello - world $%& - I am a good - guy and want to - save - the - world")
subst = " | "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.