using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - ";
string substitution = @" | ";
string input = @"Hello - world - I am a good - guy and want to - save - the - world
Hello - wor ld - I am a good - guy and want to - save - the - world
Hello - wo43rld - I am a good - guy and want to - save - the - world
Hello - world 2.0 - I am a good - guy and want to - save - the - world
Hello - world $%& - I am a good - guy and want to - save - the - world";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}