#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - "
Local $sString = "Hello - world - I am a good - guy and want to - save - the - world" & @CRLF & _
"Hello - wor ld - I am a good - guy and want to - save - the - world" & @CRLF & _
"Hello - wo43rld - I am a good - guy and want to - save - the - world" & @CRLF & _
"Hello - world 2.0 - I am a good - guy and want to - save - the - world" & @CRLF & _
"Hello - world $%& - I am a good - guy and want to - save - the - world"
Local $sSubst = " | "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)