use strict;
my $str = 'Hello - world - I am a good - guy and want to - save - the - world
Hello - wor ld - I am a good - guy and want to - save - the - world
Hello - wo43rld - I am a good - guy and want to - save - the - world
Hello - world 2.0 - I am a good - guy and want to - save - the - world
Hello - world $%& - I am a good - guy and want to - save - the - world';
my $regex = qr/^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - /mp;
my $subst = ' | ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";