re = /^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - /m
str = 'Hello - world - I am a good - guy and want to - save - the - world
Hello - wor ld - I am a good - guy and want to - save - the - world
Hello - wo43rld - I am a good - guy and want to - save - the - world
Hello - world 2.0 - I am a good - guy and want to - save - the - world
Hello - world $%& - I am a good - guy and want to - save - the - world'
subst = ' | '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result