import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - ";
final String string = "Hello - world - I am a good - guy and want to - save - the - world\n"
+ "Hello - wor ld - I am a good - guy and want to - save - the - world\n"
+ "Hello - wo43rld - I am a good - guy and want to - save - the - world\n"
+ "Hello - world 2.0 - I am a good - guy and want to - save - the - world\n"
+ "Hello - world $%& - I am a good - guy and want to - save - the - world";
final String subst = " | ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}