const regex = /^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - ', 'gm')
const str = `Hello - world - I am a good - guy and want to - save - the - world
Hello - wor ld - I am a good - guy and want to - save - the - world
Hello - wo43rld - I am a good - guy and want to - save - the - world
Hello - world 2.0 - I am a good - guy and want to - save - the - world
Hello - world \$%& - I am a good - guy and want to - save - the - world`;
const subst = ` | `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);