import Foundation
let pattern = #"^((?! - ).+?(?= - ) - ){2}(*SKIP)(*F)| - "#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello - world - I am a good - guy and want to - save - the - world
Hello - wor ld - I am a good - guy and want to - save - the - world
Hello - wo43rld - I am a good - guy and want to - save - the - world
Hello - world 2.0 - I am a good - guy and want to - save - the - world
Hello - world $%& - I am a good - guy and want to - save - the - world
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" | "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)