using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?:\/\/)?wa\.me\/\d{3,15}";
string input = @"https://wa.me/29483294837?text=
text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/2948d3294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/226495150463435?text=I'm%20interested%20in%20your%20car%20for%20sale";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}