use strict;
my $str = 'https://wa.me/29483294837?text=
text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/2948d3294837?text=I\'m%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837text=I\'m%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I\'m%20interested%20in%20your%20car%20for%20sale
https://wa.me/226495150463435?text=I\'m%20interested%20in%20your%20car%20for%20sale';
my $regex = qr/(?:https?:\/\/)?wa\.me\/\d{3,15}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}