import Foundation
let pattern = #"(?:https?:\/\/)?wa\.me\/\d{3,15}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://wa.me/29483294837?text=
text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/2948d3294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/226495150463435?text=I'm%20interested%20in%20your%20car%20for%20sale
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)