// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https?:\/\/)?wa\.me\/\d{3,15}").unwrap();
let string = "https://wa.me/29483294837?text=
text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/2948d3294837?text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/s29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/29483294837text=I'm%20interested%20in%20your%20car%20for%20salehttps://wa.me/29483294837?text=I'm%20interested%20in%20your%20car%20for%20sale
https://wa.me/226495150463435?text=I'm%20interested%20in%20your%20car%20for%20sale";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}