# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^a-zA-Z0-9]+/\n/g;t' <<< "\"Lorem ipsum (dolor) sit amet, consectetur [adipiscing] elit, sed do {eiusmod} tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud {[(*&^%$#@!exercitation<>;:'\"}]) ullamco laboris nisi ut aliquip ex ea commodo consequat.\""