re = /[^a-zA-Z0-9]+/
str = '"Lorem ipsum (dolor) sit amet, consectetur [adipiscing] elit, sed do {eiusmod} tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud {[(*&^%$#@!exercitation<>;:\'"}]) ullamco laboris nisi ut aliquip ex ea commodo consequat."'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result