import Foundation
let pattern = #"[^a-zA-Z0-9]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##""Lorem ipsum (dolor) sit amet, consectetur [adipiscing] elit, sed do {eiusmod} tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud {[(*&^%$#@!exercitation<>;:'"}]) ullamco laboris nisi ut aliquip ex ea commodo consequat.""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)