# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^a-zA-Z0-9]+"
test_str = "\"Lorem ipsum (dolor) sit amet, consectetur [adipiscing] elit, sed do {eiusmod} tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud {[(*&^%$#@!exercitation<>;:'\"}]) ullamco laboris nisi ut aliquip ex ea commodo consequat.\""
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.