import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z0-9]+";
final String string = "\"Lorem ipsum (dolor) sit amet, consectetur [adipiscing] elit, sed do {eiusmod} tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud {[(*&^%$#@!exercitation<>;:'\"}]) ullamco laboris nisi ut aliquip ex ea commodo consequat.\"";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}