use strict;
my $str = '"Lorem ipsum (dolor) sit amet, consectetur [adipiscing] elit, sed do {eiusmod} tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud {[(*&^%$#@!exercitation<>;:\'"}]) ullamco laboris nisi ut aliquip ex ea commodo consequat."';
my $regex = qr/[^a-zA-Z0-9]+/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";