# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h{3}-\h(\S)/( - $1)/gm;t' <<< "- Right? Yeah? - Yeah.
- What's your name? - I'm... I'm Caleb.
- I'm Christina. - Beatrice."