// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\h{3}-\h(\S)").unwrap();
let string = "- Right? Yeah? - Yeah.
- What's your name? - I'm... I'm Caleb.
- I'm Christina. - Beatrice.";
let substitution = "( - $1)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}