import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\h{3}-\\h(\\S)";
final String string = "- Right? Yeah? - Yeah.\n\n"
+ "- What's your name? - I'm... I'm Caleb.\n\n"
+ "- I'm Christina. - Beatrice.";
final String subst = "( - $1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}