$re = '/\h{3}-\h(\S)/m';
$str = '- Right? Yeah? - Yeah.
- What\'s your name? - I\'m... I\'m Caleb.
- I\'m Christina. - Beatrice.';
$subst = "( - $1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;