using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h{3}-\h(\S)";
string substitution = @"( - $1)";
string input = @"- Right? Yeah? - Yeah.
- What's your name? - I'm... I'm Caleb.
- I'm Christina. - Beatrice.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}