const regex = /\h{3}-\h(\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h{3}-\\h(\\S)', 'gm')
const str = `- Right? Yeah? - Yeah.
- What's your name? - I'm... I'm Caleb.
- I'm Christina. - Beatrice.`;
const subst = `( - $1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);