package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\h{3}-\h(\S)`)
var str = `- Right? Yeah? - Yeah.
- What's your name? - I'm... I'm Caleb.
- I'm Christina. - Beatrice.`
var substitution = "( - $1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}