import Foundation
let pattern = #"\h{3}-\h(\S)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
- Right? Yeah? - Yeah.
- What's your name? - I'm... I'm Caleb.
- I'm Christina. - Beatrice.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"( - $1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)