use strict;
my $str = '- Right? Yeah? - Yeah.
- What\'s your name? - I\'m... I\'m Caleb.
- I\'m Christina. - Beatrice.';
my $regex = qr/\h{3}-\h(\S)/mp;
my $subst = '( - $1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";