# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*//gm;t' <<< "-- test
# should be \"\"
--->>> test
# should be \"--->>> test\"
<<<--- test
# should be \"<<<--- test\"
--->>>->>> test
# should be --->>>->>> test
---->>> test
# should be \"\"
test --->>> test
# should be \"test --->>> test\"
test --->>> test <<<---
# should be \"test --->>> test <<<---\"
"