const regex = /(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*', 'gm')
const str = `-- test
# should be ""
--->>> test
# should be "--->>> test"
<<<--- test
# should be "<<<--- test"
--->>>->>> test
# should be --->>>->>> test
---->>> test
# should be ""
test --->>> test
# should be "test --->>> test"
test --->>> test <<<---
# should be "test --->>> test <<<---"
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);