import Foundation
let pattern = #"(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
-- test
# should be ""
--->>> test
# should be "--->>> test"
<<<--- test
# should be "<<<--- test"
--->>>->>> test
# should be --->>>->>> test
---->>> test
# should be ""
test --->>> test
# should be "test --->>> test"
test --->>> test <<<---
# should be "test --->>> test <<<---"
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)