#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*"
Local $sString = "-- test" & @CRLF & _
" # should be """ & @CRLF & _
"--->>> test" & @CRLF & _
" # should be "--->>> test"" & @CRLF & _
"<<<--- test" & @CRLF & _
" # should be "<<<--- test"" & @CRLF & _
"--->>>->>> test" & @CRLF & _
" # should be --->>>->>> test" & @CRLF & _
"---->>> test" & @CRLF & _
" # should be """ & @CRLF & _
"test --->>> test" & @CRLF & _
" # should be "test --->>> test"" & @CRLF & _
"test --->>> test <<<---" & @CRLF & _
" # should be "test --->>> test <<<---"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)