import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*";
final String string = "-- test\n"
+ " # should be \"\"\n"
+ "--->>> test\n"
+ " # should be \"--->>> test\"\n"
+ "<<<--- test\n"
+ " # should be \"<<<--- test\"\n"
+ "--->>>->>> test\n"
+ " # should be --->>>->>> test\n"
+ "---->>> test\n"
+ " # should be \"\"\n"
+ "test --->>> test\n"
+ " # should be \"test --->>> test\"\n"
+ "test --->>> test <<<---\n"
+ " # should be \"test --->>> test <<<---\"\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}