using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*";
string substitution = @"";
string input = @"-- test
# should be ""
--->>> test
# should be ""--->>> test""
<<<--- test
# should be ""<<<--- test""
--->>>->>> test
# should be --->>>->>> test
---->>> test
# should be ""
test --->>> test
# should be ""test --->>> test""
test --->>> test <<<---
# should be ""test --->>> test <<<---""
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}