$re = '/(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*/m';
$str = '-- test
# should be ""
--->>> test
# should be "--->>> test"
<<<--- test
# should be "<<<--- test"
--->>>->>> test
# should be --->>>->>> test
---->>> test
# should be ""
test --->>> test
# should be "test --->>> test"
test --->>> test <<<---
# should be "test --->>> test <<<---"
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;