re = /(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*/m
str = '-- test
# should be ""
--->>> test
# should be "--->>> test"
<<<--- test
# should be "<<<--- test"
--->>>->>> test
# should be --->>>->>> test
---->>> test
# should be ""
test --->>> test
# should be "test --->>> test"
test --->>> test <<<---
# should be "test --->>> test <<<---"
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result