use strict;
my $str = '-- test
# should be ""
--->>> test
# should be "--->>> test"
<<<--- test
# should be "<<<--- test"
--->>>->>> test
# should be --->>>->>> test
---->>> test
# should be ""
test --->>> test
# should be "test --->>> test"
test --->>> test <<<---
# should be "test --->>> test <<<---"
';
my $regex = qr/(?:(?<!-)--->>>|<<<---(?!-))(*SKIP)(*FAIL)|--.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";