#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-HJ-NPR-Z\d]{8}[\dX][A-HJ-NPR-Z\d]{8}$"
Local $sString = "1FUYDMDB2YPF87097" & @CRLF & _
"1FAHP26W49G252740" & @CRLF & _
"WP0CA29863U153381" & @CRLF & _
"2FTRX07W53C371582" & @CRLF & _
"1FAHP26W49G252740" & @CRLF & _
"WP0CA29863U153381" & @CRLF & _
"2FTRX07W53C371582" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")