using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-HJ-NPR-Z\d]{8}[\dX][A-HJ-NPR-Z\d]{8}$";
string input = @"1FUYDMDB2YPF87097
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}