import re
regex = re.compile(r"^[A-HJ-NPR-Z\d]{8}[\dX][A-HJ-NPR-Z\d]{8}$", flags=re.MULTILINE)
test_str = ("1FUYDMDB2YPF87097\n"
"1FAHP26W49G252740\n"
"WP0CA29863U153381\n"
"2FTRX07W53C371582\n"
"1FAHP26W49G252740\n"
"WP0CA29863U153381\n"
"2FTRX07W53C371582\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")