import Foundation
let pattern = #"^[A-HJ-NPR-Z\d]{8}[\dX][A-HJ-NPR-Z\d]{8}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1FUYDMDB2YPF87097
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)