import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-HJ-NPR-Z\\d]{8}[\\dX][A-HJ-NPR-Z\\d]{8}$";
final String string = "1FUYDMDB2YPF87097\n"
+ "1FAHP26W49G252740\n"
+ "WP0CA29863U153381\n"
+ "2FTRX07W53C371582\n"
+ "1FAHP26W49G252740\n"
+ "WP0CA29863U153381\n"
+ "2FTRX07W53C371582\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}