$re = '/^[A-HJ-NPR-Z\d]{8}[\dX][A-HJ-NPR-Z\d]{8}$/m';
$str = '1FUYDMDB2YPF87097
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
1FAHP26W49G252740
WP0CA29863U153381
2FTRX07W53C371582
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);