# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:catch\s*\([^)]+\)\s*\{(?=[^\}]*\blog\.debug\b)|\G)\K([^\}]*?)(?:\blog\.debug\b[^\}]*?)/$1log.error/g;t' <<< "catch (Exception e)
{
log.debug(\"word\");
//stuff
log.debug(\"word2\");
}
function (Exception e)
{
log.debug(\"word\");
//stuff
log.debug(\"word2\");
}"