import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:catch\\s*\\([^)]+\\)\\s*\\{(?=[^\\}]*\\blog\\.debug\\b)|\\G)\\K([^\\}]*?)(?:\\blog\\.debug\\b[^\\}]*?)";
final String string = "catch (Exception e) \n"
+ "{\n"
+ " log.debug(\"word\");\n"
+ " //stuff\n"
+ " log.debug(\"word2\");\n"
+ "}\n\n"
+ "function (Exception e) \n"
+ "{\n"
+ " log.debug(\"word\");\n"
+ " //stuff\n"
+ " log.debug(\"word2\");\n"
+ "}";
final String subst = "$1log.error";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}